Error Messages
Security
Error
Cause
You are not authorized to display this page
The user must be a WorkflowGen user or administrator to access the application.
You are not a participant of the request
A request or an action can only be viewed or modified by a participant, a process manager, or a process supervisor.
You are not authorized to access this file
If downloading is secured, only a WorkflowGen Administrator, process manager, process supervisor, or participant with sufficient reading rights may access the requested files.
Incorrect request
Error
Cause
The request was not found
The request you're trying to access is not in the database.
The action was not found
The action you're trying to access is not in the database.
The action has already been done
You're attempting to perform an action that has already been closed.
Error while opening the file
The file you're trying to access is invalid.
The file was not found
The file you're trying to access is not on the server.
A file associated with the data is missing
The file associated with the data is not on the server.
Process flow errors
Error
Cause
The request is not available
The request you are trying to access does not have an In test or Active status.
The process has reached the maximum number of instances authorized for the action
The number of actions for the process has reached the limit set by the Maximum number of simultaneous instances creation per action parameter in the Administration Module Configuration panel.
The process cannot start because its definition is not valid
The request you're attempting to create is based on a process definition that contains errors.
A file associated with the data is missing
The file associated with the data does not exist or is not accessible. Check the read/write permissions of the WorkflowGen users on the folder that contains the action’s temporary files.
Action launch errors
Error
Cause
A parameter required in the process was not found
The value of a parameter required in the process is empty.
The username of the person to be assigned to was not found
If the action assignment is dynamic, the data containing the username is empty.
The username of the person to be assigned to does not correspond to a user
If the action assignment is dynamic, the name of the user contained in the data doesn't correspond to a user of the application.
An error occurred while evaluating the conditions of the transition
The condition specified for the transition has created an error at runtime. Check the syntax of the condition.
An error occurred while evaluating the conditions of the notification
The condition specified for the notification has created an error at runtime. Check the syntax of the condition.
An error occurred while evaluating the transition conditions
The action transition condition could not be evaluated. Check its syntax.
An error occurred while calling the web procedure
The application is not able to reach the URL of the web procedure or of the web service. Check that the URL is accurate and the username and password are valid.
Sub-request launch errors
Error
Cause
Missing parameter
Only when launching a sub-process action: One of the parameters required by the sub-process has not been sent by the parent request.
The sub-process was not found
The sub-process you're trying to access is not in the database or its status is not In test or Active.
The user is not declared as process requester
The requester defined for the sub-request is not associated with the sub-process requester participant.
Errors while ending an action
Error
Cause
The action has been cancelled because the timeout delay has expired
The lock of the data for the action has expired. You must set up the action again.
An error occurred while executing the web procedure
The data returned by the web procedure or web service is invalid.
License errors
Error
Cause
The number of authorized users is over. Please contact your administrator to upgrade your license.
You cannot create more than the number of users specified in your license file.
Portlet is not supported with your license. Please contact your administrator to upgrade your license.
You cannot access the RSS portal using the WorkflowGen Standard version.
Launching a process remotely is not allowed with your license. Please contact your administrator to upgrade your license.
You cannot launch remote requests using the WorkflowGen Standard version.
This operation is not allowed with your license. Please contact your administrator to upgrade your license.
You cannot change data using the WorkflowGen Archive version.
Advanced view errors
Error
Cause
This field contains one or more illegal characters
The name you entered in the Save as view window contains one or more of the following illegal characters: <
>
/
\
;
View’s name can’t be empty
You haven't given the view in the Save as view window a title.
Column identifier contains unexpected characters
The identifier you entered in the Edit columns window contains one or more of the following illegal characters: <
>
/
\
;
Column identifier must be unique
In the Edit columns window, you gave the column identifier a title that already exists.
Your function doesn’t return a value
Any function you enter in the Save as view or Edit columns windows must compute and return a value.
The browser returns an error if there is a problem in JavaScript
Depending on the browser you're using, the error message you receive may be slightly different. However, all browsers will return an error message if there is a problem in JavaScript.